Support Forums
Connection Reports

Hello,

I am learning to use the Connection Report in the Reports tab, and I seem to be running into some issues. I've included some screenshots that should clarify the issue.

6178192146fdf
6178192146fa3

As you can see, I am trying to model some multiconductor cables in a schematic. I accomplish this by using different wire segments and connecting them together and changing their colors and thicknesses at certain points. I then hide the wire numbers of the smaller connectors and only show the wire name of the main cable. I am not sure if this is the best way to do this in Electra, but I've found it somewhat sufficient so far.

6178192fb556a

My problem is with the Connection Report item in the Reports tab. When I generate a report, it works very inconsistently. As you can see, cable 1 shows all 3 conductors on one side but not the other, cable 2 shows 1 conductor, cable 3, 4, 5, and 6 are completely absent, and cable 7 shows all conductors on both sides, but does not generate any information. I am really not sure why this is so inconsistent.

Hello, I am learning to use the Connection Report in the Reports tab, and I seem to be running into some issues. I've included some screenshots that should clarify the issue. ![6178192146fdf](serve/attachment&path=6178192146fdf) ![6178192146fa3](serve/attachment&path=6178192146fa3) As you can see, I am trying to model some multiconductor cables in a schematic. I accomplish this by using different wire segments and connecting them together and changing their colors and thicknesses at certain points. I then hide the wire numbers of the smaller connectors and only show the wire name of the main cable. I am not sure if this is the best way to do this in Electra, but I've found it somewhat sufficient so far. ![6178192fb556a](serve/attachment&path=6178192fb556a) My problem is with the Connection Report item in the Reports tab. When I generate a report, it works very inconsistently. As you can see, cable 1 shows all 3 conductors on one side but not the other, cable 2 shows 1 conductor, cable 3, 4, 5, and 6 are completely absent, and cable 7 shows all conductors on both sides, but does not generate any information. I am really not sure why this is so inconsistent.

I should also note setting the legs of the cable to "NoName" simply makes them appear on the connection report as a cable with a number "NoName" which is not ideal.

I should also note setting the legs of the cable to "NoName" simply makes them appear on the connection report as a cable with a number "NoName" which is not ideal.

Hi Nick,

Thanks for reaching out and providing detailed information.

Inconsistency in connection report:
Please allow us to clarify the 3 Cond. 18AWG cable is a 3 cores cable with Brown, Green, and Blue that each core should connect from one symbol to another?

If yes, we strongly recommend you not to connect them using the main wires but to connect them separately to symbols so that you could generate the connection report correctly. You could refer to the image below on how to connect the wires with symbols:
6178c65cf1785

With this, the connection report data will be correct:
6178c6a83657b

If this is not what you want to achieve, could you please let us know what are the expected results in the connection report?

Also, if the problem persists after using the suggested way to connect symbols and wires, kindly click on the report bug icon, ensure you have enabled the option “Share my drawing to support team”, and let us know which part of the report is incorrect. Thanks in advance.
6178c6e1d989d

With regards to some connections not shown in the connection report, chances are the wires are not connected to symbols properly. To check if a wire is connected properly, you could select the wire and check if its endpoint is red in color:
6178c703af565

Besides that, if a wire does not have any cable assigned to it, the cable information will be blank in the connection report. Chances are there is no cable assigned to wire 7 and therefore the cable information is black.

NoName appears in report
Yes, this is expected behaviour if the wire is set to NoName. If you need the wire name to be hidden and not named as NoName, you could right-click on the wire and choose Hide Wire Name.

Hope it helps.

Hi Nick, Thanks for reaching out and providing detailed information. **Inconsistency in connection report:** Please allow us to clarify the 3 Cond. 18AWG cable is a 3 cores cable with Brown, Green, and Blue that each core should connect from one symbol to another? If yes, we strongly recommend you not to connect them using the main wires but to connect them separately to symbols so that you could generate the connection report correctly. You could refer to the image below on how to connect the wires with symbols: ![6178c65cf1785](serve/attachment&path=6178c65cf1785) With this, the connection report data will be correct: ![6178c6a83657b](serve/attachment&path=6178c6a83657b) If this is not what you want to achieve, could you please let us know what are the expected results in the connection report? Also, if the problem persists after using the suggested way to connect symbols and wires, kindly click on the report bug icon, ensure you have enabled the option “Share my drawing to support team”, and let us know which part of the report is incorrect. Thanks in advance. ![6178c6e1d989d](serve/attachment&path=6178c6e1d989d) With regards to some connections not shown in the connection report, chances are the wires are not connected to symbols properly. To check if a wire is connected properly, you could select the wire and check if its endpoint is red in color: ![6178c703af565](serve/attachment&path=6178c703af565) Besides that, if a wire does not have any cable assigned to it, the cable information will be blank in the connection report. Chances are there is no cable assigned to wire 7 and therefore the cable information is black. **NoName appears in report** Yes, this is expected behaviour if the wire is set to NoName. If you need the wire name to be hidden and not named as NoName, you could right-click on the wire and choose Hide Wire Name. Hope it helps.
94
2
2
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft